Nav Active não funciona

Boa tarde, Comunidade.

Estou desenvolvendo um formulário e dentro dele tem uma Nav com duas abas apenas. A primeira aba deveria estar ativa ao carregar a página.

Porém ao colocar a classe="active" a opção da Aba fica marcada, porém não é exibido seu conteúdo. No entanto, se eu clicar na segunda aba o conteúdo é exibido. O que me leva a concluir que não é um problema no href.

CÓDIGO HTML:

<div class="form-group col-md-11">
     <ul class="nav nav-tabs" role="tablist" id="myTab">
          <li role="presentation" class="active"><a href="#identificacao" id="identificacaoAba" role="tab" data-toggle="tab">Identificação</a></li>
          <li role="presentation"><a href="#produtos" id="produtosAba" role="tab" data-toggle="tab">Produtos</a></li>
     </ul>
</div>

CÓDIGO JAVASCRIPT:

$('#myTab a[href="#identificacao"').tab('show');

Imagem ao carregar a página: primeira.png

Imagem depois de clicar na aba produtos e voltar para identificação: segunda.png

Alguém já passou por algo parecido e poderia me ajudar?

Atenciosamente, Leonardo Fioretti.

compartilhar
  1. Você vai ver essas setas em qualquer página de pergunta. Com elas, você pode dizer se uma pergunta ou uma resposta foram relevantes ou não.
  2. Edite sua pergunta ou resposta caso queira alterar ou adicionar detalhes.
  3. Caso haja alguma dúvida sobre a pergunta, adicione um comentário. O espaço de respostas deve ser utilizado apenas para responder a pergunta.
  4. Se o autor da pergunta marcar uma resposta como solucionada, esta marca aparecerá.
  5. Clique aqui para mais detalhes sobre o funcionamento do fluig Forum!

1 resposta

Não é a resposta que estava procurando? Procure outras perguntas com as tags navbuttons active formulario form ou faça a sua própria pergunta.