Versão atual:

java.lang.RuntimeException: /opt/fluig/appserver - Atualização Fluig - Linux

Bom dia, Comunidade.

Estou tentando atualizar a aplicação Fluig, em um servidor Linux, da versão 1.5.13 para a versão 1.6.5 (conforme orientado pela TOTVS em chamado isso seria possível).

Porém me deparei com a seguinte mensagem de erro:

java.lang.RuntimeException: /opt/fluig/appserver
        at com.fluig.wcm.update.FluigUpdate.updateFilesForEachVersion(FluigUpdate.java:221)
        at com.fluig.wcm.update.FluigUpdate.executeUpdates(FluigUpdate.java:181)
        at com.fluig.wcm.update.FluigUpdate.main(FluigUpdate.java:114)
Caused by: java.nio.file.DirectoryNotEmptyException: /opt/fluig/appserver
        at sun.nio.fs.UnixCopyFile.move(UnixCopyFile.java:445)
        at sun.nio.fs.UnixFileSystemProvider.move(UnixFileSystemProvider.java:262)
        at java.nio.file.Files.move(Files.java:1395)
        at com.fluig.install.util.AppServerUtil.extractAppServer(AppServerUtil.java:31)
        at com.fluig.wcm.update.Update_1_5_20.updateFiles(Update_1_5_20.java:93)
        at com.fluig.wcm.update.Update_1_5_20.executePreUpdate(Update_1_5_20.java:54)
        at com.fluig.wcm.update.AbstractUpdate.executeUpdate(AbstractUpdate.java:85)
        at com.fluig.wcm.update.FluigUpdate.updateFilesForEachVersion(FluigUpdate.java:211)
        ... 2 more

Alguém já passou por algo parecido e poderia me auxiliar nessa atualização?

Agradeço desde já o apoio.

Atenciosamente, Leonardo Fioretti.

Versão (1):

Ver a versão formatada

java.lang.RuntimeException: /opt/fluig/appserver - Atualização Fluig - Linux

Comentário

new question