Parâmetros em Relatórios

Estou desenvolvendo um relatório e preciso criar um parâmetro para solicitar antes da execução do relatório afim de filtrar alguns dados.

Criei um parâmetro do tipo listBox, usando um dataset, conforme print em anexo.

O problema é que o listBox não carrega. Ao executar o relatório, abre a tela de parâmetros, porém o listBox está vazio.

Se removo o parâmetro e coloco o dataset no corpo do relatório, ele traz os valores do dataset corretamente. Ou seja, o dataset está correto. Só a carga do dataset dentro do parâmetro não parece estar correta.

É necessário executar mais algum método para que os dados apareçam dentro do parâmetro listBox ?

Obrigado

compartilhar
  • A carga do meu dataset está no método Initialize. Pelo que vi, só chama o Initialize após dar os na tela de parametros. E por isso não está trazendo os valores no parâmetro.

    Existe um método que execute antes de abrir a tela de parâmetros ?

    Maicon Roberto Correa   3 months ago
  1. Você vai ver essas setas em qualquer página de pergunta. Com elas, você pode dizer se uma pergunta ou uma resposta foram relevantes ou não.
  2. Edite sua pergunta ou resposta caso queira alterar ou adicionar detalhes.
  3. Caso haja alguma dúvida sobre a pergunta, adicione um comentário. O espaço de respostas deve ser utilizado apenas para responder a pergunta.
  4. Se o autor da pergunta marcar uma resposta como solucionada, esta marca aparecerá.
  5. Clique aqui para mais detalhes sobre o funcionamento do fluig Forum!

1 resposta

Não é a resposta que estava procurando? Procure outras perguntas com as tags relatorio datasets ou faça a sua própria pergunta.